libxfce4ui-4.12.1

libxfce4ui の概要

The libxfce4ui package contains GTK+ 2 widgets that are used by other Xfce applications.

本パッケージは LFS-8.3 において正しくビルドでき動作することが確認されています。

パッケージ情報

libxfce4ui の依存パッケージ

必須

GTK+-2.24.32, Xfconf-4.12.1

推奨

任意

GTK-Doc-1.29, HTML::Parser-3.72, Glade

ユーザー情報: http://wiki.linuxfromscratch.org/blfs/wiki/libxfce4ui

libxfce4ui のインストール

以下のコマンドを実行して libxfce4ui をビルドします。

./configure --prefix=/usr --sysconfdir=/etc &&
make

このパッケージにテストスイートはありません。

root ユーザーになって以下を実行します。

make install

コマンド説明

--enable-gtk-doc: GTK-Doc をインストール済で API ドキュメントを再構築する場合に指定します。

パッケージ構成

インストールプログラム: なし
インストールライブラリ: libxfce4kbd-private-{2,3}.so, libxfce4ui-{1,2}.so
インストールディレクトリ: /etc/xdg/xfce4, /usr/include/xfce4/libxfce4kbd-private-2, /usr/include/xfce4/libxfce4ui-{1,2}, /usr/share/gtk-doc/html/libxfce4ui

概略説明

libxfce4kbd-private-2.so

is a private Xfce library for sharing code between Xfwm4 and Xfce4 Settings.

libxfce4ui-1.so

contains widgets that are used by other Xfce applications.

最終更新日: 2018-08-23 08:17:20 +0900