WebKitGTK+-2.16.6

WebKitGTK+ の概要

The WebKitGTK+ package is a port of the portable web rendering engine WebKit to the GTK+ 3 and GTK+ 2 platforms.

本パッケージは LFS-8.0 において正しくビルドでき動作することが確認されています。

パッケージ情報

  • ダウンロード (HTTP): https://webkitgtk.org/releases/webkitgtk-2.16.6.tar.xz

  • ダウンロード MD5 sum: 0e2d142a586e4ff79cf0324f4fdbf20c

  • ダウンロードサイズ: 14 MB

  • 必要ディスク容量: 1.0 GB (119 MB installed)

  • 概算ビルド時間: 56 SBU (using parallelism=4, extimated 120 SBUs using one core)

WebKitGTK+ の依存パッケージ

必須

Cairo-1.14.10, CMake-3.9.1, enchant-1.6.0, gst-plugins-base-1.12.2, GTK+-2.24.31, GTK+-3.22.18, ICU-59.1, libgudev-231, libsecret-0.18.5, libsoup-2.58.2, libwebp-0.6.0, Mesa-17.1.6, Ruby-2.4.1, SQLite-3.20.0, Which-2.21

推奨

任意

GTK-Doc-1.26, HarfBuzz-1.4.8, LLVM-4.0.1, Wayland-1.14.0, Hyphen, and MathML

ユーザー情報: http://wiki.linuxfromscratch.org/blfs/wiki/webkitgtk

WebKitGTK+ のインストール

Installation of WebKitGTK+

[注意]

注意

You must rebuild Perl with -Dusethreads if LFS was built without that option. LFS made this change in April 2017.

First, fix a build issue with ICU >= 59:

sed -i 's/unsigned short/char16_t/'            \
       Source/JavaScriptCore/API/JSStringRef.h \
       Source/WebKit2/Shared/API/c/WKString.h  &&

sed -i '/stdbool.h/ a#include <uchar.h>' \
       Source/JavaScriptCore/API/JSBase.h

以下のコマンドを実行して WebKitGTK+ をビルドします。

mkdir -vp build &&
cd        build &&

CFLAGS=-Wno-expansion-to-defined  \
CXXFLAGS=-Wno-expansion-to-defined \
cmake -DCMAKE_BUILD_TYPE=Release  \
      -DCMAKE_INSTALL_PREFIX=/usr \
      -DCMAKE_SKIP_RPATH=ON       \
      -DPORT=GTK                  \
      -DLIB_INSTALL_DIR=/usr/lib  \
      -DUSE_LIBHYPHEN=OFF         \
      -DENABLE_MINIBROWSER=ON     \
      -Wno-dev .. &&
make

このパッケージには有効なテストスイートがありません。 しかしソースディレクトリ内には、単純なウェブブラウザー Programs/GtkLauncher が含まれています。 この起動に失敗したとしたら、ビルドに問題があることが分かります。

[注記]

注記

When installing, the Makefile does some additional compiling and linking. If you do not have Xorg in /usr, the LIBRARY_PATH and PKG_CONFIG_PATH variables need to be defined for the root user. If using sudo to assume root, use the -E option to pass your current environment variables for the install process.

root ユーザーになって以下を実行します。

make install &&

install -vdm755 /usr/share/gtk-doc/html/webkit{2,dom}gtk-4.0 &&
install -vm644  ../Documentation/webkit2gtk-4.0/html/*   \
                /usr/share/gtk-doc/html/webkit2gtk-4.0       &&
install -vm644  ../Documentation/webkitdomgtk-4.0/html/* \
                /usr/share/gtk-doc/html/webkitdomgtk-4.0

コマンド説明

-DUSE_LIBHYPHEN=OFF: This switch disables default automatic hyphenation implementation. You need to install Hyphen, if you wish to enable it (replacing OFF with ON or just removing the switch).

-DENABLE_MINIBROWSER=ON: This switch enables the Mini Browser compilation and install.

-DUSE_LIBNOTIFY=OFF: Use this switch if you do not have libnotify installed.

-DUSE_SYSTEM_MALLOC=ON: This switch enables building against the system installed malloc.

-DENABLE_GEOLOCATION=OFF: Use this switch if you don't want to install GeoClue-2.4.7.

-DENABLE_GTKDOC=ON: Use this switch if GTK-Doc-1.26 is installed and you wish to rebuild and install the API documentation.

パッケージ構成

インストールプログラム: jsc, MiniBrowser
インストールライブラリ: libjavascriptcoregtk-4.0.so, libwebkit2gtk-4.0.so
インストールディレクトリ: /usr/include/webkitgtk-4.0, /usr/lib{,exec}/webkit2gtk-4.0, /usr/share/gtk-doc/html/webkit{2,dom}gtk-4.0

概略説明

jsc

コマンドラインユーティリティー。 ウェブブラウザーのコンテキスト外にて JavaScript を実行します。

MiniBrowser

is a very simple graphical browser.

libjavascriptcoregtk-4.0.so

jsclibwebkit2gtk-4.0.so により利用されるコアな JavaScript API 関数を提供します。

libwebkit2gtk-4.0.so

WebKit2 API 関数を提供します。

最終更新日: 2017-08-17 05:38:22 +0900