keybinder2-0.3.0

Introduction to keybinder2

The keybinder2 package contains a utility library registering global X keyboard shortcuts.

本パッケージは LFS-8.0 において正しくビルドでき動作することが確認されています。

Package Information

keybinder2 Dependencies

Required

GTK+-2.24.31

Recommended

Optional

GTK-Doc-1.26 and Lua-5.3.4 (currently broken, because older lua version is required)

User Notes: http://wiki.linuxfromscratch.org/blfs/wiki/keybinder2

Installation of keybinder2

Install keybinder2 by running the following commands:

./configure --prefix=/usr --disable-lua &&
make

This package does not come with a test suite.

Now, as the root user:

make install

Command Explanations

--disable-lua: Use this switch to disable Lua-5.3.4 bindings (currently broken, because older lua version is required).

--enable-gtk-doc: GTK-Doc をインストール済で API ドキュメントを再構築する場合に指定します。

Contents

Installed Programs: None
Installed Library: libkeybinder.so and /usr/lib/python2.7/site-packages/keybinder/_keybinder.so
Installed Directories: /usr/lib/python2.7/site-packages/keybinder and /usr/share/gtk-doc/html/keybinder

Short Descriptions

libkeybinder.so

is the library that registers global X keyboard shortcuts.

最終更新日: 2017-02-21 09:33:44 +0900