gtk-vnc-0.7.2

Gtk VNC の概要

Gtk VNC パッケージは GTK+ における VNC ビューワーウィジェットを提供します。 これは完全に非同期で動作する処理ルーチンにより構築され、しかも単一のスレッドで動作します。

本パッケージは LFS-8.3 において正しくビルドでき動作することが確認されています。

パッケージ情報

Gtk VNC の依存パッケージ

必須

GnuTLS-3.5.19, GTK+-3.24.0, libgcrypt-1.8.3

推奨

任意

Cyrus SASL-2.1.26, PulseAudio-12.2, libview

ユーザー情報: http://wiki.linuxfromscratch.org/blfs/wiki/gtk-vnc

Gtk VNC のインストール

以下のコマンドを実行して Gtk VNC をビルドします。

./configure --prefix=/usr  \
            --with-gtk=3.0 \
            --enable-vala  \
            --without-sasl &&
make

このパッケージにテストスイートはありません。

root ユーザーになって以下を実行します。

make install

コマンド説明

--with-gtk=3.0: このスイッチは GTK+ 2 ではなく GTK+ 3 をビルドするようにします。

--enable-vala: このスイッチは Vala バインディングを有効にします。 Vala-0.42.0 をインストールしていない場合は、本オプションを取り除いてください。

--without-sasl: このスイッチは、認証処理にあたって Cyrus SASL を利用しないことを指示します。 Cyrus SASL をインストールしていて、これを有効にする場合は本パラメーターを取り除いてください。

パッケージ構成

インストールプログラム: gvnccapture
インストールライブラリ: libgtk-vnc-2.0.so, libgvnc-1.0.so, libgvncpulse-1.0.so
インストールディレクトリ: /usr/include/gtk-vnc-2.0, /usr/include/gvnc-1.0, /usr/include/gvncpulse-1.0

概略説明

gvnccapture

VNC ビューアーからの画面キャプチャーを行います。

libgtk-vnc-2.0.so

Gtk VNC に対する GTK+ 3 バインディングを提供します。

libgvnc-1.0.so

Gtk VNC に対する GObject バインディングを提供します。

libgvncpulse-1.0.so

Gtk VNC に対する PulseAudio ブリッジです。

最終更新日: 2018-08-31 10:48:05 +0900