Kate-18.08.0

Kate の概要

The Kate package contains an advanced KF5 based graphical text editor.

本パッケージは LFS-8.3 において正しくビルドでき動作することが確認されています。

パッケージ情報

Kate の依存パッケージ

必須

KDE Frameworks-5.49.0,

Optional

libgit2

User Notes: http://wiki.linuxfromscratch.org/blfs/wiki/kate5

Kate のインストール

以下のコマンドを実行して Kate をビルドします。

mkdir build &&
cd    build &&

cmake -DCMAKE_INSTALL_PREFIX=$KF5_PREFIX  \
      -DCMAKE_BUILD_TYPE=Release          \
      -DBUILD_TESTING=OFF                 \
      -Wno-dev .. &&
make

このパッケージにテストスイートはありません。

root ユーザーになって以下を実行します。

make install

パッケージ構成

インストールプログラム: kate, kwrite
インストールライブラリ: libkdeinit5_kate.so, libkdeinit5_kwrite.so
インストールディレクトリ: $KF5_PREFIX/lib/plugins/ktexteditor, $KF5_PREFIX/lib/plugins/plasma/dataengine, $KF5_PREFIX/share/doc/HTML/*/{kate,katepart,kwrite}, $KF5_PREFIX/share/{kateproject,katexmltools}, $KF5_PREFIX/share/kxmlgui5/{kate,katebuild,katecloseexceptplugin}, $KF5_PREFIX/share/kxmlgui5/{katectags,katefiletree,kategdb}, $KF5_PREFIX/share/kxmlgui5/{katekonsole,kateopenheaderplugin}, $KF5_PREFIX/share/kxmlgui5/{kateproject,katesearch,katesnippets}, $KF5_PREFIX/share/kxmlgui5/{katesql,katesymbolviewer,katexmltools}, $KF5_PREFIX/share/kxmlgui5/{kwrite,tabswitcher}, $KF5_PREFIX/share/plasma/plasmoids/org.kde.plasma.katesessions

概略説明

kate

is an advanced text editor for kde.

kwrite

is a text editor for KDE, that is a light version of kate.

最終更新日: 2018-08-23 00:18:12 +0900