XviD-1.3.5

Introduction to XviD

XviD is an MPEG-4 compliant video CODEC.

本パッケージは LFS-8.3 において正しくビルドでき動作することが確認されています。

Package Information

XviD Dependencies

Optional

yasm-1.3.0

User Notes: http://wiki.linuxfromscratch.org/blfs/wiki/xvid

Installation of XviD

[注記]

注記

This package tarball expands to xvidcore, not the expected xvidcore-1.3.5.

Install XviD by running the following commands:

cd build/generic &&
sed -i 's/^LN_S=@LN_S@/& -f -v/' platform.inc.in &&
./configure --prefix=/usr &&
make

This package does not come with a test suite.

Now, as the root user:

sed -i '/libdir.*STATIC_LIB/ s/^/#/' Makefile &&
make install &&

chmod -v 755 /usr/lib/libxvidcore.so.4.3 &&

install -v -m755 -d /usr/share/doc/xvidcore-1.3.5/examples &&
install -v -m644 ../../doc/* /usr/share/doc/xvidcore-1.3.5 &&
install -v -m644 ../../examples/* \
    /usr/share/doc/xvidcore-1.3.5/examples

Command Explanations

sed -i 's/^LN_S=@LN_S@/& -f -v/' platform.inc.in: Fix error during make install if reintalling or upgrading.

sed -i '/libdir.*STATIC_LIB/ s/^/#/' Makefile: This command disables installing the static library.

Contents

Installed Programs: None
Installed Library: libxvidcore.so
Installed Directory: /usr/share/doc/xvidcore-1.3.5

Short Descriptions

libxvidcore.so

provides functions to encode and decode most MPEG-4 video data.

最終更新日: 2018-08-25 05:13:05 +0900