kwave-18.08.0

KWave の概要

KWave パッケージは KF5 ベースのサウンドエディターアプリケーションを提供します。

本パッケージは LFS-8.3 において正しくビルドでき動作することが確認されています。

パッケージ情報

KWave の依存パッケージ

必須

AudioFile-0.3.6, fftw-3.3.8, id3lib-3.8.3, KDE Frameworks-5.49.0

推奨

任意

Doxygen-1.8.14

ユーザー情報: http://wiki.linuxfromscratch.org/blfs/wiki/kwave

KWave のインストール

以下のコマンドを実行して KWave をビルドします。

mkdir build &&
cd    build &&

cmake -DCMAKE_INSTALL_PREFIX=$KF5_PREFIX \
      -DCMAKE_BUILD_TYPE=Release         \
      -DBUILD_TESTING=OFF                \
      -Wno-dev .. &&
make

このパッケージにテストスイートはありません。

root ユーザーになって以下を実行します。

make install

パッケージ構成

インストールプログラム: kwave
インストールライブラリ: libkwave.so, libkwavegui.so, 29 plugins
インストールディレクトリ: $KF5_PREFIX/lib/plugins/kwave, $KF5_PREFIX/share/doc/HTML/en/kwave

概略説明

kwave

KDE フレームワーク 5 上にて構築されているサウンドエディター。

最終更新日: 2018-08-22 05:14:23 +0900