gst-plugins-ugly-1.12.2

Introduction to GStreamer Ugly Plug-ins

The GStreamer Ugly Plug-ins is a set of plug-ins considered by the GStreamer developers to have good quality and correct functionality, but distributing them might pose problems. The license on either the plug-ins or the supporting libraries might not be how the GStreamer developers would like. The code might be widely known to present patent problems.

本パッケージは LFS-8.0 において正しくビルドでき動作することが確認されています。

Package Information

GStreamer Ugly Plug-ins Dependencies

Required

gst-plugins-base-1.12.2

Recommended

Optional

libmad-0.15.1b, libmpeg2-0.5.1, libcdio-0.94 (for CD-ROM drive access), mpg123-1.25.6, Valgrind-3.13.0, libsidplay, OpenCore AMR, Orc, and TwoLame

User Notes: http://wiki.linuxfromscratch.org/blfs/wiki/gst10-plugins-ugly

Installation of GStreamer Ugly Plug-ins

[注記]

注記

If you need a plugin for a given dependency, that dependency needs to be installed before this application.

Install GStreamer Ugly Plug-ins by running the following commands:

./configure --prefix=/usr \
            --with-package-name="GStreamer Ugly Plugins 1.12.2 BLFS" \
            --with-package-origin="http://www.linuxfromscratch.org/blfs/view/svn/" &&
make

To test the results, issue: make check.

Now, as the root user:

make install

Contents

Installed Programs: None
Installed Libraries: Several plugins under /usr/lib/gstreamer-1.0
Installed Directories: /usr/share/gstreamer-1.0/presets and /usr/share/gtk-doc/html/gst-plugins-ugly-plugins-1.0

最終更新日: 2017-08-17 05:38:22 +0900