Polkit-Qt-0.112.0

Polkit-Qt の概要

Polkit-Qt は Qt 環境での PolicyKit に対する API を提供します。

本パッケージは LFS-8.3 において正しくビルドでき動作することが確認されています。

パッケージ情報

Polkit-Qt の依存パッケージ

必須

CMake-3.12.1, Polkit-0.114, Qt-5.11.1

ユーザー情報: http://wiki.linuxfromscratch.org/blfs/wiki/polkit-qt

Polkit-Qt のインストール

以下のコマンドを実行して Polkit-Qt をビルドします。

mkdir build &&
cd    build &&

cmake -DCMAKE_INSTALL_PREFIX=/usr \
      -DCMAKE_BUILD_TYPE=Release  \
      -Wno-dev .. &&
make

このパッケージにテストスイートはありません。

root ユーザーになって以下を実行します。

make install

コマンド説明

-DCMAKE_BUILD_TYPE=Release: This switch is used to apply higher level of the compiler optimizations.

パッケージ構成

インストールプログラム: なし
インストールライブラリ: libpolkit-qt5-agent-1.so, libpolkit-qt5-core-1.so, libpolkit-qt5-gui-1.so
インストールディレクトリ: /usr/include/polkit-qt5-1, /usr/lib/cmake/PolkitQt5-1

最終更新日: 2018-08-21 10:36:12 +0900