Popt-1.16

Popt の概要

popt パッケージは popt ライブラリを提供するもので、コマンドラインオプションを処理するプログラムが利用します。

本パッケージは LFS-8.1 において正しくビルドでき動作することが確認されています。

パッケージ情報

ユーザー情報: http://wiki.linuxfromscratch.org/blfs/wiki/popt

Popt のインストール

以下のコマンドを実行して popt をビルドします。

./configure --prefix=/usr --disable-static &&
make

Doxygen-1.8.13 をインストール済であって API ドキュメントをビルドする場合は doxygen を実行します。

コンパイル結果をテストする場合は make check を実行します。

root ユーザーとなって以下を実行します。

make install

API ドキュメントをビルドした場合は root ユーザーになって以下を実行しドキュメントをインストールします。

install -v -m755 -d /usr/share/doc/popt-1.16 &&
install -v -m644 doxygen/html/* /usr/share/doc/popt-1.16

コマンド説明

--disable-static: このスイッチはスタティックライブラリをインストールしないようにします。

パッケージ構成

インストールプログラム: なし
インストールライブラリ: libpopt.so
インストールディレクトリ: /usr/share/doc/popt-1.16

概略説明

libpopt.so

コマンドラインオプションを処理するために利用します。

最終更新日: 2017-08-21 07:06:11 +0900