libgusb-0.2.11

libgusb の概要

The libgusb package contains the GObject wrappers for libusb-1.0 that makes it easy to do asynchronous control, bulk and interrupt transfers with proper cancellation and integration into a mainloop.

本パッケージは LFS-8.1 において正しくビルドでき動作することが確認されています。

パッケージ情報

libgusb の依存パッケージ

必須

libusb-1.0.21

推奨

任意

GTK-Doc-1.26

ユーザー情報: http://wiki.linuxfromscratch.org/blfs/wiki/libgusb

libgusb のインストール

以下のコマンドを実行して libgusb をビルドします。

./configure --prefix=/usr --disable-static &&
make

ビルド結果をテストする場合は make check を実行します。

root ユーザーになって以下を実行します。

make install

コマンド説明

--disable-static: このスイッチはスタティックライブラリをインストールしないようにします。

--enable-gtk-doc: GTK-Doc をインストール済で API ドキュメントを再構築する場合に指定します。

パッケージ構成

インストールプログラム: なし
インストールライブラリ: libgusb.so
インストールディレクトリ: /usr/include/gusb-1, /usr/share/gtk-doc/html/gusb

概略説明

libgusb.so

libgusb API 関数を提供します。

最終更新日: 2017-08-21 07:06:11 +0900