libbytesize-1.4

Introduction to libbytesize

The libbytesize package is a library facilitates the common operations with sizes in bytes.

本パッケージは LFS-8.3 において正しくビルドでき動作することが確認されています。

Package Information

libbytesize Dependencies

Required

PCRE-8.42

Optional

GTK-Doc-1.29, Python-2.7.15, six-1.11.0 (python module for tests), pocketlint (python module for one test), and polib (python module for one test)

User Notes: http://wiki.linuxfromscratch.org/blfs/wiki/libbytesize

Installation of libbytesize

Install libbytesize by running the following commands:

./configure --prefix=/usr &&
make

If you have the optional python modules installed, the regression tests can be run with: make check.

Now, as the root user:

make install

Command Explanations

--with-python3: Use this switch to prefer Python 3 if both Python 2 and Python 3 are installed.

Contents

Installed Programs: None
Installed Library: libbytesize.so
Installed Directories: /usr/include/bytesize, /usr/share/gtk-doc/html/libbytesize, and /usr/lib/python{2.7,3.6}/site-packages/bytesize

最終更新日: 2018-08-17 09:08:56 +0900