Falkon-3.0.1

Introduction to falkon

Falkon is a KDE web browser using the QtWebEngine rendering engine. It was previously known as QupZilla. It aims to be a lightweight web browser available through all major platforms.

Although falkon is now part of KDE, it can be installed without KDE (with the loss of kwallet functionality, and of translations of the (not-installed) example hellopython.py script).

本パッケージは LFS-8.3 において正しくビルドでき動作することが確認されています。

Package Information

falkon Dependencies

Required

extra-cmake-modules-5.49.0, qtwebengine-5.11.1

Optional

gnome-keyring-3.28.2, KDE Frameworks-5.49.0 (for ki18n if installing the translations of hellopython.py, or for kwallet and its dependencies), and PySide2 for experimental Python plugins (compiling this from source is very slow).

User Notes: http://wiki.linuxfromscratch.org/blfs/wiki/falkon

Installation of falkon

Install falkon by running the following commands:

Unless you have installed both PySide2 and ki18n, remove the translations for the sample hellopython.py script:

rm -rf po/

In case you wish to run the tests, fix one of them so that it will work correctly with both Qt-5.10 and Qt-5.11:

sed -i 's/"5.11.", 5) == 0 ? 1 : 2/"5.10.", 5) >= 0 ? 2 : 1/' \
  autotests/webviewtest.cpp

Now build the program:

mkdir build &&
cd    build &&

cmake -DCMAKE_INSTALL_PREFIX=/usr \
      -DCMAKE_BUILD_TYPE=Release  \
      -DBUILD_TESTING=OFF         \
      .. &&

make

To test the results, issue: make test. All tests should pass. If any fail, the full results will be in Testing/Temporary/LastTest.log.

Now, as the root user:

make install

If you have installed Pyside2 you will want to examine the hellopython.py which is in the scripts/ directory, and perhaps copy it to your home directory.

Command Explanations

sed -i 's/"5.11.", 5) == 0 ? 1 : 2/"5.10.", 5) >= 0 ? 2 : 1/' ...: This test previously looked for QtWebengine-5.10 which had changed its result compared to earlier versions. In the move to Qt-5.11 the version was bumped but the results were swapped. Change it to examine if the version is at least 5.10, and to swap the expected results back.

Contents

Installed Programs: falkon
Installed Library: libFalkonPrivate.so.3
Installed Directory: ${FALKON_PREFIX}/lib/plugins, ${FALKON_PREFIX}/share/falkon.

Short Descriptions

falkon

is a web browser which uses qtwebengine.

libFalkonPrivate.so.3

contains functions used by falkon.

最終更新日: 2018-08-28 07:41:22 +0900