libxfce4util-4.12.1

libxfce4util の概要

libxfce4util パッケージは、Xfce デスクトップ環境に対する基本的なユーティリティライブラリを提供します。

本パッケージは LFS-8.3 において正しくビルドでき動作することが確認されています。

パッケージ情報

libxfce4util の依存パッケージ

必須

GLib-2.58.0

任意

GTK-Doc-1.29

ユーザー情報: http://wiki.linuxfromscratch.org/blfs/wiki/libxfce4util

libxfce4util のインストール

以下のコマンドを実行して libxfce4util をビルドします。

./configure --prefix=/usr &&
make

このパッケージにテストスイートはありません。

root ユーザーになって以下を実行します。

make install

コマンド説明

--enable-gtk-doc: GTK-Doc をインストール済で API ドキュメントを再構築する場合に指定します。

パッケージ構成

インストールプログラム: xfce4-kiosk-query
インストールライブラリ: libxfce4util.so
インストールディレクトリ: /usr/include/xfce4, /usr/share/gtk-doc/html/libxfce4util

概略説明

xfce4-kiosk-query

Queries the given capabilities of <module> for the current user and reports whether the user has the capabilities or not. This tool is mainly meant for system administrators to test their Kiosk setup.

libxfce4util.so

contains basic utility functions for the Xfce desktop environment.

最終更新日: 2018-08-23 08:17:20 +0900