Flash Player-26.0.0.137

Flash Player の概要

Flash Player is a multi-platform client runtime to view and interact with SWF content, distributed as a browser plugin for both NPAPI (Gecko and WebKit) and PPAPI (Blink) based browsers.

本パッケージは LFS-8.0 において正しくビルドでき動作することが確認されています。

Downloads

NPAPI plugin for Gecko (Mozilla) and WebKit 64-bit

NPAPI plugin for Gecko (Mozilla) and WebKit 32-bit

PPAPI plugin for Blink (QTWebEngine and Chromium) 64-bit

PPAPI plugin for Blink (QTWebEngine and Chromium) 32-bit

Chromium Launcher (required for Chromium)

[注記]

注記

Download this file via wget as:

wget https://github.com/foutrelis/chromium-launcher/archive/v5.tar.gz \
     -O chromium-launcher-v5.tar.gz

Flash Player の依存パッケージ (NPAPI)

必須

Cairo-1.14.10, cURL-7.55.1, Graphite2-1.3.10, GTK+-2.24.31, libffi-3.2.1, PCRE-8.41, Mesa-17.1.6, NSS-3.32,

任意 (実行時)

Epiphany-3.24.2, Firefox-55.0.1, LibreOffice-5.4.0.3, Midori-0.5.11, SeaMonkey-2.48, Thunderbird-52.2.1

Flash Player Dependencies (PPAPI)

Optional (runtime)

Chromium-60.0.3112.101 (required if installing Chromium Launcher) or QupZilla-2.1.2

ユーザー情報: http://wiki.linuxfromscratch.org/blfs/wiki/flashplayer

Flash Player のインストール

NPAPI Plug-in Installation (Mozilla and WebKit)

以下のコマンドを実行して Flash Player NPAPI プラグインをインストールします。

mkdir flashplayer &&
cd flashplayer    &&
case $(uname -m) in
    x86_64) tar -xf ../flash_player_npapi_linux.x86_64.tar.gz
    ;;
    i?86)   tar -xf ../flash_player_npapi_linux.i386.tar.gz
    ;;
esac

Now, as the root user:

install -vdm755 /usr/lib/mozilla/plugins &&
install -vm755 libflashplayer.so /usr/lib/mozilla/plugins/libflashplayer.so &&
install -vm755 usr/bin/flash-player-properties /usr/bin &&
install -vm644 usr/share/applications/flash-player-properties.desktop \
               /usr/share/applications &&
for size in 16 22 24 32 48
do
    install -vdm755 usr/share/icons/hicolor/${size}x${size}/apps/ &&
    install -vm644 usr/share/icons/hicolor/${size}x${size}/apps/flash-player-properties.png \
                   /usr/share/icons/hicolor/${size}x${size}/apps
done &&
update-desktop-database

PPAPI Plug-in Installation (QTWebEngine and Chromium)

Install the Flash Player PPAPI plugin by running the following commands:

mkdir flashplayer &&
cd flashplayer    &&
case $(uname -m) in
    x86_64) tar -xf ../flash_player_ppapi_linux.x86_64.tar.gz
    ;;
    i?86)   tar -xf ../flash_player_ppapi_linux.i386.tar.gz
    ;;
esac

Now, as the root user:

install -vdm755 /usr/lib/PepperFlash &&
install -vDm755 libpepflashplayer.so /usr/lib/PepperFlash/ &&
install -vm644 manifest.json /usr/lib/PepperFlash/

Chromium Lanucher Installation

Chromium Lanucher is a wrapper for Chromium that adds the PeppperFlash installation path and plug-in flags to the Chromium command line if the PPAPI plugin is found at runtime. Install Chromium Launcher with the following commands:

tar -xf chromium-launcher-5.tar.gz &&
cd chromium-launcher-5             &&
make PREFIX=/usr

Now, as the root user:

mv -v /usr/bin/chromium /usr/bin/chromium-orig &&
make PREFIX=/usr install-strip

Contents

Installed Programs: /usr/bin/chromium
Installed Libraries: /usr/lib/mozilla/plugins/libflashplayer.so and/or /usr/lib/PepperFlash/libpepflashplayer.so
Installed Directories: /usr/lib/PepperFlash

最終更新日: 2017-07-25 08:20:38 +0900