Phonon-backend-gstreamer-4.9.0

Phonon-backend-gstreamer の概要

このパッケージは GStreamer メディアフレームワークを利用する、Phonon のバックエンドライブラリを提供します。

本パッケージは LFS-8.3 において正しくビルドでき動作することが確認されています。

パッケージ情報

Phonon-backend-gstreamer の依存パッケージ

必須

gstreamer-1.14.2, libxml2-2.9.8, phonon-4.10.1

推奨

ユーザー情報: http://wiki.linuxfromscratch.org/blfs/wiki/phonon-backend-gstreamer

Phonon-backend-gstreamer のインストール

[注記]

注記

This package unpacks to the directory phonon-gstreamer-4.9.0.

以下のコマンドを実行して Phonon-backend-gstreamer をビルドします。

mkdir build &&
cd    build &&

cmake -DCMAKE_INSTALL_PREFIX=/usr    \
      -DCMAKE_BUILD_TYPE=Release     \
      -DPHONON_BUILD_PHONON4QT5=ON   \
      -Wno-dev .. &&
make

root ユーザーになって以下を実行します。

make install

コマンド説明

-DCMAKE_BUILD_TYPE=Release: このスイッチは、コンパイラーの最適化オプションを最高レベルにて適用することを指示します。

-DPHONON_BUILD_PHONON4QT5=ON: This switch is used to ensure that Qt5 version of the backend is built even if Qt4 is present.

パッケージ構成

インストールプログラム: なし
インストールライブラリ: phonon_gstreamer.so
インストールディレクトリ: /usr/lib/qt5/plugins/phonon4qt5_backend

最終更新日: 2018-08-21 10:36:12 +0900