VTE-0.52.2

VTE の概要

VTE パッケージは、端末エミュレーターに対しての termcap ファイル実装を提供します。

本パッケージは LFS-8.3 において正しくビルドでき動作することが確認されています。

パッケージ情報

VTE の依存パッケージ

必須

GTK+-3.24.0, libxml2-2.9.8, pcre2-10.31

推奨

任意

GTK-Doc-1.29, Vala-0.42.0, Glade

ユーザー情報: http://wiki.linuxfromscratch.org/blfs/wiki/vte

VTE のインストール

以下のコマンドを実行して VTE をビルドします。

./configure --prefix=/usr          \
            --sysconfdir=/etc      \
            --disable-static       \
            --enable-introspection &&
make

ビルド結果をテストする場合は make check を実行します。

root ユーザーになって以下を実行します。

make install

コマンド説明

--enable-introspection: This switch enables Gobject Introspection bindings. Remove if you don't have gobject-introspection-1.58.0 installed.

--without-gnutls: Add this switch if you don't have GnuTLS-3.5.19 installed.

--disable-static: このスイッチはスタティックライブラリをインストールしないようにします。

--enable-gtk-doc: GTK-Doc をインストール済で API ドキュメントを再構築する場合に指定します。

パッケージ構成

インストールプログラム: vte-2.91
インストールライブラリ: libvte-2.91.so
インストールディレクトリ: /usr/include/vte-2.91, /usr/share/gtk-doc/html/vte-2.91

概略説明

vte-2.91

VTE ライブラリに対するテストアプリケーション。

libvte-2.91.so

is a library which implements a terminal emulator widget for GTK+ 3.

最終更新日: 2018-08-24 10:49:51 +0900