totem-pl-parser-3.26.1

Totem PL Parser の概要

The Totem PL Parser package contains a simple GObject-based library used to parse multiple playlist formats.

本パッケージは LFS-8.3 において正しくビルドでき動作することが確認されています。

パッケージ情報

Totem PL Parser の依存パッケージ

必須

GMime-3.2.0 または GMime-2.6.23, libsoup-2.64.0

推奨

任意

GTK-Doc-1.29, LCOV, libquvi >= 0.9.1 and libquvi-scripts - if they are installed, then lua-socket (git) is necessary for the tests

ユーザー情報: http://wiki.linuxfromscratch.org/blfs/wiki/totem-pl-parser

Totem PL Parser のインストール

以下のコマンドを実行して totem-pl-parser をビルドします。

mkdir build &&
cd build &&
meson --prefix /usr --default-library shared .. &&
ninja

ビルド結果をテストする場合は ninja test を実行します。 /parser/parsing/podcast_medium というテストは LFS 環境の中では失敗します。

root ユーザーになって以下を実行します。

ninja install

パッケージ構成

インストールプログラム: なし
インストールライブラリ: libtotem-plparser-mini.so, libtotem-plparser.so
インストールディレクトリ: /usr/include/totem-pl-parser, /usr/share/gtk-doc/html/totem-pl-parser

概略説明

libtotem-plparser.so

is the Totem Playlist Parser library.

libtotem-plparser-mini.so

is the Totem Playlist Parser library, mini version.

最終更新日: 2018-08-31 04:27:14 +0900