libsecret-0.18.5

Introduction to libsecret

The libsecret package contains a GObject based library for accessing the Secret Service API.

本パッケージは LFS-8.0 において正しくビルドでき動作することが確認されています。

Package Information

libsecret Dependencies

Required

GLib-2.52.3

Recommended

Optional

GTK-Doc-1.26 and docbook-xml-4.5, docbook-xsl-1.79.1, and libxslt-1.1.29 (to build manual pages)

Optional (Required for the testsuite)

D-Bus Python-1.2.4, Gjs-1.48.6, and PyGObject-2.28.6

Runtime Dependency

gnome-keyring-3.20.1

[注記]

注記

Any package requiring libsecret expects GNOME Keyring to be present at runtime.

User Notes: http://wiki.linuxfromscratch.org/blfs/wiki/libsecret

Installation of libsecret

Install libsecret by running the following commands:

./configure --prefix=/usr --disable-static &&
make

Now, as the root user:

make install

Command Explanations

--disable-static: このスイッチはスタティックライブラリをインストールしないようにします。

--enable-gtk-doc: GTK-Doc をインストール済で API ドキュメントを再構築する場合に指定します。

--disable-manpages: Use this switch if you have not installed libxslt-1.1.29 and DocBook packages.

--disable-gcrypt: Use this switch if you have not installed the recommended dependency of libgcrypt-1.8.0.

Contents

Installed Program: secret-tool
Installed Library: libsecret-1.so
Installed Directories: /usr/include/libsecret-1 and /usr/share/gtk-doc/html/libsecret-1

Short Descriptions

secret-tool

is a command line tool that can be used to store and retrieve passwords.

libsecret-1.so

contains the libsecret API functions.

最終更新日: 2017-02-19 11:01:35 +0900