evolution-data-server-3.36.4

Introduction to Evolution Data Server

The Evolution Data Server package provides a unified backend for programs that work with contacts, tasks, and calendar information. It was originally developed for Evolution (hence the name), but is now used by other packages as well.

本パッケージは LFS-9.1 において正しくビルドでき動作することが確認されています。

Package Information

Evolution Data Server Dependencies

Required

Berkeley DB-5.3.28, Gcr-3.36.0, libical-3.0.8, libsecret-0.20.3, NSS-3.54, and SQLite-3.32.3.

Recommended

Recommended (Runtime)

Optional

GTK-Doc-1.32, MIT Kerberos V5-1.18.2, a MTA (that provides a sendmail command), OpenLDAP-2.4.50, and libphonenumber

User Notes: http://wiki.linuxfromscratch.org/blfs/wiki/evolution-data-server

Installation of Evolution Data Server

Install Evolution Data Server by running the following commands:

mkdir build &&
cd    build &&

cmake -DCMAKE_INSTALL_PREFIX=/usr   \
      -DSYSCONF_INSTALL_DIR=/etc    \
      -DENABLE_VALA_BINDINGS=ON     \
      -DENABLE_INSTALLED_TESTS=ON   \
      -DENABLE_GOOGLE=ON            \
      -DWITH_OPENLDAP=OFF           \
      -DWITH_KRB5=OFF               \
      -DENABLE_INTROSPECTION=ON     \
      -DENABLE_GTK_DOC=OFF          \
      -DWITH_SYSTEMDUSERUNITDIR=no  \
      .. &&
make

To test the results, issue: make test.

Now, as the root user:

make install

Command Explanations

-DENABLE_GOOGLE=ON: This default flag enables access to google services via libgdata-0.17.12 and also enables the Google Authentication option.

-DENABLE_VALA_BINDINGS=ON: This switch enables building the Vala bindings. Remove if you don't have Vala-0.48.7 installed.

-DENABLE_GTK_DOC=OFF: This switch disables building the API documentation. It is broken for this package due to the use of a long deprecated gtk-doc program that is no longer available.

-DWITH_SYSTEMDUSERUNITDIR=no: This switch disables installing the systemd units, which are not used for a Sysv build.

[注記]

注記

To enable many of the optional dependencies, review the information from cmake -L CMakeLists.txt for the necessary parameters you must pass to the cmake command.

Contents

Installed Programs: None
Installed Libraries: libcamel-1.2.so, libebackend-1.2.so, libebook-1.2.so, libebook-contacts-1.2.so, libecal-2.0.so, libedata-book-1.2.so, libedata-cal-2.0.so, libedataserver-1.2.so, libedataserverui-1.2.so, and libetestserverutils.so
Installed Directories: /usr/include/evolution-data-server, /usr/lib{,exec}/evolution-data-server, /usr/share/installed-tests/evolution-data-server, and /usr/share/pixmaps/evolution-data-server

Short Descriptions

libcamel-1.2.so

is the Evolution MIME message handling library.

libebackend-1.2.so

is the utility library for Evolution Data Server Backends.

libebook-1.2.so

is the client library for Evolution address books.

libebook-contacts-1.2.so

is the client library for Evolution contacts.

libecal-1.2.so

is the client library for Evolution calendars.

libedata-book-1.2.so

is the backend library for Evolution address books.

libedata-cal-1.2.so

is the backend library for Evolution calendars.

libedataserver-1.2.so

is the utility library for Evolution Data Server.

libedataserverui-3.0.so

is the GUI utility library for Evolution Data Server.

libetestserverutils.so

is the server test utility library for Evolution Data Server.

最終更新日: 2020-07-04 07:05:34 +0900