libusb-compat-0.1.5

libusb-compat の概要

libusb-compat パッケージは、libusb-0.1 パッケージとそっくり同じ見た目や動きを目指したライブラリです。 libusb-1.0 の API へのアップグレードを行っていない各種パッケージ類にとって、必要となる互換レイヤーとなるものです。

本パッケージは LFS-8.3 において正しくビルドでき動作することが確認されています。

パッケージ情報

libusb-compat の依存パッケージ

必須

libusb-1.0.22

ユーザー情報: http://wiki.linuxfromscratch.org/blfs/wiki/libusb-compat

libusb-compat のインストール

以下のコマンドを実行して libusb-compat をビルドします。

./configure --prefix=/usr --disable-static &&
make

このパッケージにテストスイートはありません。

root ユーザーになって以下を実行します。

make install

パッケージ構成

インストールプログラム: libusb-config
インストールライブラリ: libusb.so
インストールディレクトリ: なし

概略説明

libusb-config

determines the compile and linker flags that should be used to compile and link programs that use libusb.

libusb.so

libusb-0.1 の互換ライブラリ。 ただし libusb-1.0 を利用して機能拡張しています。

最終更新日: 2018-08-19 06:53:19 +0900