libgrss-0.7.0

libgrss の概要

The libgrss package contains a library designed to manipulate RSS and Atom feeds.

本パッケージは LFS-10.0 において正しくビルドでき動作することが確認されています。

パッケージ情報

追加のダウンロード

libgrss の依存パッケージ

必須

libsoup-2.70.0

ユーザー情報: http://wiki.linuxfromscratch.org/blfs/wiki/libgrss

libgrss のインストール

以下のコマンドを実行して libgrss をビルドします。

patch -Np1 -i ../libgrss-0.7.0-bugfixes-1.patch &&
autoreconf -fiv &&
./configure --prefix=/usr --disable-static &&
make

ビルド結果をテストする場合は make check を実行します。

root ユーザーになって以下を実行します。

make install

コマンド説明

--disable-static: このスイッチはスタティックライブラリをインストールしないようにします。

--enable-gtk-doc: GTK-Doc をインストール済で API ドキュメントを再構築する場合に指定します。

パッケージ構成

インストールプログラム: なし
インストールライブラリ: libgrss.so
インストールディレクトリ: /usr/include/libgrss, /usr/share/doc/libgrss-0.7.0

概略説明

libgrss.so

RSS フィードを扱う API 関数を提供します。

最終更新日: 2020-08-17 13:26:53 +0900